Annons

WordPress kan blockera Google FLoC med fyra rader kod

Wordpress Logo
Annons

WordPress kan blockera Googles nya spårningsteknik Federated Learning of Cohorts (FLoC).

Enligt uppgift anser utvecklarna bakom WordPress att FLoC är en säkerhetsrisk, och att publiceringsplattformen kan komma att blockera tekniken med en kommande uppdatering.

Lästips: Optimera och snabba upp WordPress – 20 bästa tipsen för din sajt

Redan idag har andra utvecklare och appar meddelat att de inte tänker ställa sig bakom FLoC. Bland annat webbläsarna Brave, Duckduckgo och Vivaldi menar att FLoC bör blockeras.

Och med fyra rader kod i WordPress ska plattformen enkelt kunna blockera Google från att spåra användare med FLoC.

function disable_floc($headers) {
    $headers['Permissions-Policy'] = 'interest-cohort=()';
    return $headers;
  }
 
add_filter('wp_headers', 'disable_floc');

Anledningen till att WordPress kanske blockerar FLoC är förstålig när man läser vad Electronic Frontier Foundation (EFF) skriver på sin webbsajt.

Annons

The technology will avoid the privacy risks of third-party cookies, but it will create new ones in the process. It may also exacerbate many of the worst non-privacy problems with behavioral ads, including discrimination and predatory targeting.

Google vill att FLoC ska vara ett nytt, bättre sätt att låta webbläsaren profilera användarna baserat på surfhistorik. Men riskerna enligt EEF är att tekniken behåller samma integritetskränkande problem som dagens tredjepartskakor.

Lästips: Så löser du Internal Server Error-problem med WordPress

Redan med WordPress 5.8 kan FLoC-blockeringen träda i kraft. Den som uppdaterar WordPress och ändå vill låta Google spåra användarna med nya tekniken kan enkelt göra det via ett plugin eller åsidosätta de fyra raderna med kod.

Du kan läsa en detaljerad artikel om FLoC-blockeringen på WordPress.org här.